Xplico.org
http://forum.xplico.org/

XI no network interface and not decoding pcap files
http://forum.xplico.org/viewtopic.php?f=3&t=554
Page 1 of 1

Author:  vsk [ Sat Apr 19, 2014 8:15 am ]
Post subject:  XI no network interface and not decoding pcap files

Ciao!
I seems impossible to get XI work on Slackware 14.1.
Everything looks fine unless I create a session. In live sessions the is no network interface in dropdown list. Not even loopback.
But in file sessions after uploading a file it just does nothing. Pcap file is not even shown in file list. The CLI seems to work fine.
Any ideas?

Grazie mille!

Author:  gianluca.costa [ Sat Apr 19, 2014 8:41 am ]
Post subject:  Re: XI no network interface and not decoding pcap files

Hi,
give us the time to install the distro and check it (the issue).

Ciao.
Gianluca

Author:  vsk [ Mon Apr 21, 2014 3:21 pm ]
Post subject:  Re: XI no network interface and not decoding pcap files

Thanx!
Have all the time you need.
I had problem building it so had to define DLT_IPV4 and DPT_IPV6. Also had to remove the "/../" in tcp garbage and udp garbage Makefiles to fix the path to libndpi.a and finally hat do define DLT_PPI in ppi.c
Thanx again!

Author:  gianluca.costa [ Mon Apr 21, 2014 7:40 pm ]
Post subject:  Re: XI no network interface and not decoding pcap files

Which Python version is used in Slackware 14.1?

Author:  vsk [ Tue Apr 22, 2014 10:10 am ]
Post subject:  Re: XI no network interface and not decoding pcap files

2.7.5 by default. I've installed 3.1.1 but there is no difference...

Author:  gianluca.costa [ Tue Apr 22, 2014 5:00 pm ]
Post subject:  Re: XI no network interface and not decoding pcap files

Ok.
Try to patch your Xplico source code with the tgz attached.
Attachment:
xplico_python3.1.tgz

Ciao.
Gianluca

Author:  vsk [ Wed May 14, 2014 7:02 am ]
Post subject:  Re: XI no network interface and not decoding pcap files

Ciao!
I'm sorry it took me so long to reply. I've patched the source and I'm able to put a .pcap file into the "new" directory and XI shows decoded data. But this is the only way XI can display pcap data. However I'm still unable to monitor live stream within XI and didn't managed to find a way to do it from the CLI. Is it possible?
Grazie!

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/