View unanswered posts | View active topics It is currently Fri Apr 28, 2017 11:59 am



Post new topic Reply to topic  [ 7 posts ] 
 XI no network interface and not decoding pcap files 
Author Message

Joined: Fri Mar 28, 2014 6:59 pm
Posts: 8
Reply with quote
Post XI no network interface and not decoding pcap files
Ciao!
I seems impossible to get XI work on Slackware 14.1.
Everything looks fine unless I create a session. In live sessions the is no network interface in dropdown list. Not even loopback.
But in file sessions after uploading a file it just does nothing. Pcap file is not even shown in file list. The CLI seems to work fine.
Any ideas?

Grazie mille!


Sat Apr 19, 2014 8:15 am
Profile
Site Admin

Joined: Wed Sep 16, 2009 10:09 pm
Posts: 390
Reply with quote
Post Re: XI no network interface and not decoding pcap files
Hi,
give us the time to install the distro and check it (the issue).

Ciao.
Gianluca


Sat Apr 19, 2014 8:41 am
Profile WWW

Joined: Fri Mar 28, 2014 6:59 pm
Posts: 8
Reply with quote
Post Re: XI no network interface and not decoding pcap files
Thanx!
Have all the time you need.
I had problem building it so had to define DLT_IPV4 and DPT_IPV6. Also had to remove the "/../" in tcp garbage and udp garbage Makefiles to fix the path to libndpi.a and finally hat do define DLT_PPI in ppi.c
Thanx again!


Mon Apr 21, 2014 3:21 pm
Profile
Site Admin

Joined: Wed Sep 16, 2009 10:09 pm
Posts: 390
Reply with quote
Post Re: XI no network interface and not decoding pcap files
Which Python version is used in Slackware 14.1?


Mon Apr 21, 2014 7:40 pm
Profile WWW

Joined: Fri Mar 28, 2014 6:59 pm
Posts: 8
Reply with quote
Post Re: XI no network interface and not decoding pcap files
2.7.5 by default. I've installed 3.1.1 but there is no difference...


Tue Apr 22, 2014 10:10 am
Profile
Site Admin

Joined: Wed Sep 16, 2009 10:09 pm
Posts: 390
Reply with quote
Post Re: XI no network interface and not decoding pcap files
Ok.
Try to patch your Xplico source code with the tgz attached.
Attachment:
xplico_python3.1.tgz

Ciao.
Gianluca


You do not have the required permissions to view the files attached to this post.


Tue Apr 22, 2014 5:00 pm
Profile WWW

Joined: Fri Mar 28, 2014 6:59 pm
Posts: 8
Reply with quote
Post Re: XI no network interface and not decoding pcap files
Ciao!
I'm sorry it took me so long to reply. I've patched the source and I'm able to put a .pcap file into the "new" directory and XI shows decoded data. But this is the only way XI can display pcap data. However I'm still unable to monitor live stream within XI and didn't managed to find a way to do it from the CLI. Is it possible?
Grazie!


Wed May 14, 2014 7:02 am
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by Vjacheslav Trushkin for Free Forums/DivisionCore.