Xplico.org
http://forum.xplico.org/

Compile error on slackware 12.1
http://forum.xplico.org/viewtopic.php?f=3&t=54
Page 1 of 1

Author:  spoon [ Sun Nov 22, 2009 7:26 am ]
Post subject:  Compile error on slackware 12.1

I get this during compile
cc -rdynamic -I/usr/local/src/xplico/xplico-0.5.3/include -I/usr/local/src/xplico/xplico-0.5.3/common/include -I/usr/local/src/xplico/xplico-0.5.3/dissectors/include -I/usr/local/src/xplico/xplico-0.5.3/capt_dissectors/include -I/usr/local/src/xplico/xplico-0.5.3/dispatch/include -Wall -fPIC -D_FILE_OFFSET_BITS=64 -DXPL_PEDANTIC_STATISTICS=1 -g -ggdb -O0 -DFTBL_SORT=1 -DXPL_CHECK_CODE=1 -DXPL_X86=1 -DGEOIP_LIBRARY=0 -DLOG_DIS_VAR_NAME=dis_mms_log_id -shared -Wl,-soname,dis_mms.so -o dis_mms.so dis_log.o mms.o mms_decode.o -lz
/usr/lib/gcc/i486-slackware-linux/4.2.3/../../../../i486-slackware-linux/bin/ld: errno: TLS definition in /lib/libc.so.6 section .tbss mismatches non-TLS reference in /usr/lib/gcc/i486-slackware-linux/4.2.3/../../../libz.so
/lib/libc.so.6: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[2]: *** [dis_mms.so] Error 1
make[2]: Leaving directory `/usr/local/src/xplico/xplico-0.5.3/dissectors/mms'
make[1]: *** [subdir] Error 1
make[1]: Leaving directory `/usr/local/src/xplico/xplico-0.5.3/dissectors'
make: *** [subdir] Error 1

Author:  carlos.gacimartin [ Sun Nov 22, 2009 12:43 pm ]
Post subject:  Re: Compile error on slackware 12.1

Hello Spoon, it is a strange error, as Xplico has been tested in Debian and Ubuntu Linux. Perhaps you need to update some library or gcc (please try this). Anyway, i have searched the web and i have found these two issues:

- Problem with your compiler (may be generating 64bits code while it should generate 32 bits, and viceversa)
http://issues.apache.org/jira/browse/STDCXX-555

- A problem of Xplico, but i don't think this may be the problem, quickly i haven't found this variable in Xplico's code.
http://www.linuxquestions.org/questions/programming-9/errno-tls-definition-...mismatches-nontls-def..-572343/
http://www.raditha.com/blog/archives/001119.html

So, please try to update your gcc and libc6 library to the last available and if you still get the error, please tell us the version of them than you're using.

Thanks.

Author:  spoon [ Mon Nov 23, 2009 9:46 pm ]
Post subject:  Re: Compile error on slackware 12.1 work arround

I had problems updating gcc so i tried a workaround. I downloaded the ubuntu pkg and ran
alien -t xplico_0.5.3_i386.deb to convert to a slackware .tgx pkg. This installed and is working properly. I will attempt to compile for documentation purposes once i get gcc compiled.
Thx for the help
spoon

Author:  gianluca.costa [ Wed Nov 25, 2009 6:28 pm ]
Post subject:  Re: Compile error on slackware 12.1

Hi Spoon,
you can try to remove "-D_FILE_OFFSET_BITS=64" from xplico-0.5.3/Makefile and xplico-0.5.3/system/dema/Makefile

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/