Xplico.org
http://forum.xplico.org/

web interface: "not found" or blank page
http://forum.xplico.org/viewtopic.php?f=3&t=443
Page 2 of 2

Author:  rafael [ Tue Sep 11, 2012 12:53 pm ]
Post subject:  Re: web interface: "not found" or blank page

It worked, thank you.

Author:  vsk [ Wed Nov 23, 2016 8:17 pm ]
Post subject:  Re: web interface: "not found" or blank page

I usually get hard time building and setting up Xplico, but this time I'm stuck.
After troubleshooting it for couple of hours and still a blank screen I gave up. I'm getting the following error in xplico_error.log

[:error] [pid 32165] [client 127.0.0.1:44858] PHP Stack trace:
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 1. {main}() /opt/xplico/xi/app/webroot/index.php:0
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 2. Dispatcher->dispatch() /opt/xplico/xi/app/webroot/index.php:86
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 3. Dispatcher->_invoke() /opt/xplico/xi/cake/dispatcher.php:197
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 4. Controller->constructClasses() /opt/xplico/xi/cake/dispatcher.php:212
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 5. Controller->loadModel() /opt/xplico/xi/cake/libs/controller/controller.php:502
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 6. ClassRegistry->init() /opt/xplico/xi/cake/libs/controller/controller.php:637
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 7. Model->__construct() /opt/xplico/xi/cake/libs/class_registry.php:142
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 8. Model->setSource() /opt/xplico/xi/cake/libs/model/model.php:483
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 9. DboSqlite3->listSources() /opt/xplico/xi/cake/libs/model/model.php:777
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 10. DboSource->fetchAll() /opt/xplico/xi/app/plugins/datasources/models/datasources/dbo/dbo_sqlite3.php:242
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 11. DboSource->execute() /opt/xplico/xi/cake/libs/model/datasources/dbo_source.php:411
[:error] [pid 32165] [client 127.0.0.1:44858] PHP 12. DboSqlite3->_execute() /opt/xplico/xi/cake/libs/model/datasources/dbo_source.php:254

I'm using PHP 5.6, because with PHP 7.0 I get

[:error] [pid 32434] [client 127.0.0.1:45234] PHP Parse error: syntax error, unexpected 'new' (T_NEW) in /opt/xplico/xi/cake/libs/inflector.php on line 303

and if I fix it, there are LOTS more of this error.
Any help will be much appreciated.

System is ubuntu 16.04.

Thanx!

Author:  vsk [ Wed Nov 23, 2016 8:27 pm ]
Post subject:  Re: web interface: "not found" or blank page

Fixed.
php5-sqlite3 was NOT installed.

Page 2 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/